Title

Message

Confirm

Want to earn a free VoiceBot Pro license? We're looking for VoiceBot translators!
<< DiscussionsReply

Voicebot keeps resetting Mic levels

Avatar from Gravatar.com
Strangefate
8 discussion posts
Hey,

I've been running into the problem that my mic level in Windows 10 keeps resetting to 34...

Turns out the offender is Voicebot, every few seconds it resets the levels to 34, might be everytime it registers speech (from me or random background noise), not sure.

I can't find an option within Voicebot to disable this or set a ldesired evel within the app, so before I go fishing for any INI files or registry entries about it, I figured I'd ask here.

Closing Voicebot fixes the issue and I've tried closing any other apps that could use a mic (like Skype). Also clicking off the windows setting about letting apps take exclusive control of the mic, nothing helps, Voicebot is botting my mic!
Mar 21, 2016  • #1
Keith Lammers (BFS)'s profile on WallpaperFusion.com
It shouldn't be VoiceBot itself that's causing this to happen, as we don't have any code in VoiceBot to control the Mic level. However, VoiceBot uses the Windows Speech Recognition, so perhaps there's an option in the properties for your mic (Control Panel > Sound > right-click the mic and choose Properties), or in the Control Panel > Speech Recognition options?
Mar 23, 2016  • #2
Avatar from Gravatar.com
The Bacon Nation
8 discussion posts
I have this same issue, only for me it likes volume at 81. I theorize it has something to do with an update to windows speech recognition. For me this started a few months ago, and unfortunately, has all but ruined voicebot. Because I no longer have control over my mic volume when VB is on, I can't set my mic back to a level where the background noise doesn't muddle up the given commands. I've been unable to locate any settings within windows to stop it. It only happens when I run voicebot, though to be fair, that is also the only time windows speech recognition would be used in my case. I bought keys for all my computers, and the issue affects them all the same. Example of this happening: https://youtu.be/BjLOVwRDtxQ
Mar 24, 2016  • #3
Avatar from Gravatar.com
Strangefate
8 discussion posts
Hey Keith, I figured yes.

I've gone through all the related windows options but there's nothing left to change or try there. Like Bacon, Voicebot is the only speech recognition program I use so it may be just that it's the only one triggering the problem.

Ultimately what I did was run another small tool in the background that every second sets the mic volume to the specified value.

Bacon, you may want to try the same.

I'm using NirCmd which is free: http://www.nirsoft.net/utils/nircmd.html and incidentally lets you control a lot of other things, which you then can run with Voicebot macros if you want.

To lock the mic volume to the value you want, run it with these parameters: nircmd.exe loop 172800 1000 setsysvolume 55000 microphone

the 1000 are miliseconds, so in this case it will set the volume to your value every second, can also go down to 500 for a half second...

The 55000 is the volume you want from a max of 65535 ...just do the math to figure out the number you need for your desired value.

I put it into a BAT file and made another one with the command taskkill /IM nircmd.exe /f to kill the process when I want to stop NirCmd from locking the volume.

You can put the first BAT file in your windows start up so it's always there automatically when you boot up too.

My bat command looks like this:
start C:\Users\%Username%\Documents\!Misc\Automation\Nircmd\nircmd.exe loop 172800 1000 setsysvolume 55000 microphone

Just change the folder to NirCmd to whatever you have.

Best solution I could come up with, works great so far...
Mar 24, 2016  • #4
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Would you guys be able to try the following?
  • Right-click the Sound icon in the system tray and choose "Recording devices"
  • Click the Communications tab
  • Set it to "Do Nothing"

I found that among some other suggestions in this thread: http://www.tomshardware.com/answers/id-1670664/microphone-adjusting.html. Not sure if it will work, but figured it's worth a try!
Mar 24, 2016  • #5
Avatar from Gravatar.com
Strangefate
8 discussion posts
Hey Keith,

It definitely did something, now the volume only resets to 34 once a minute or 2, as opposed to every 3-5 seconds... Windows must have a lot of double redundancy built in...

Thanks for finding that, I did a lot of reading myself but that tip never came up. At the end of the day, nobody had a solution beyond making sure programs like Skype, that do have a feature to regulated volume automatically as you speak, have that option turned off... which commonly didn't solve the problem for the people having the issue.

I'll keep using the tool I got to lock the volume for now, I'm sure Voicebot has nothing to do with it and it's all part of Windows' Voice features somehow...

Thanks!
Mar 24, 2016  • #6
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Ok, interesting! I'll keep digging around too, to see if I can find any other options that might affect this. I can't get it to happen on my system, so I'm wondering if the sound card drivers have something to do with it as well.
Mar 29, 2016  • #7
Keith Lammers (BFS)'s profile on WallpaperFusion.com
I was looking around some more, trying to find a solution to this, but didn't have much luck. Quick question though, when you go to your microphone properties and click the "Levels" tab, do you have a "Microphone Boost" slider, or just the "Microphone" slider?
May 13, 2016  • #8
Avatar from Gravatar.com
Strangefate
8 discussion posts
You're persistent :)
It does have a microphone boost yes... turning it off or all the way up doesn't do anything as far as the volume issue goes.

That said, my Surface tablets' mic doesn't have a mic boost and doesn't have the problem either... so maybe there's some relation there.
May 16, 2016  • #9
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Yeah, I read somewhere that the boost can affect the level in some cases too, but my mic doesn't have the boost either so I couldn't test at all
May 16, 2016  • #10
Avatar from Gravatar.com
4lchemist
1 discussion post
I had the same problem and found out, that the windows speech recognition has a registry entry, which defines the default value for the microphone level. You can find it under "Computer\HKEY_CURRENT_USER\Software\Microsoft\Speech\RecoProfiles\Tokens\{pick the right one}\{begins with DAC9F}\Volume" then there is a DWORD value. Keep in mind, that 100% are 10000 on a decimal basis (hex value is 2710).
• Attachment [protected]: Reg_sound_default_value.JPG [103,260 bytes]
Jul 19, 2018  • #11
Avatar from Gravatar.com
DAB42
31 discussion posts
I had the same issue with another program like voice bot , My fix was to yell into the mic when setting windows voice volume levels and this way windows did not adjust the mic way up. Sloppy fix but effective.
Jul 20, 2018  • #12
Was this helpful?  Login to Vote  Login to Vote
<< DiscussionsReply