Title

Message

Confirm

<< DiscussionsReply

REQUEST: listen for only a single safe word to turn on/off listening for all other commands

Avatar from Gravatar.com
steve58280
5 discussion posts
I use voicebot with my voice recording software, I need to say "record" and have voicebot run a macro that starts record and then tells voicebot to stop listening for commands and just listen for the safe word, which will run a macro to reenable listening for other commands and do some processing on the clip recorded (because I'm singing words that confuse voicebot) - Is that possible?
18 days ago  • #1
Keith Lammers (BFS)'s profile on WallpaperFusion.com
On the Settings > Configuration tab, you can set the Global Command Prefix option to make it so that VoiceBot only responds if you say the prefix followed by the Macro command.

e.g. If you set it to "computer", and your Macro command was "record," then you'd say "computer record" to activate it.

Hopefully that helps!
17 days ago  • #2
Avatar from Gravatar.com
steve58280
5 discussion posts
Thanks for the reply Keith, yes I am aware of that feature, which is great except when you are issuing lots of complex sets of commands. I speak to the computer a lot during recording sessions so having to say a single word every time is really klunky. The good news you already have the code figured out for what I'm requesting and if you think about my request- parking voicebot in a mode of listening for a single safe word to turn on listening for all commands would be a really nice feature, lots of people would take to this functionality. Please let me know- thanks this is one of the best pc products out there !
16 days ago (modified 16 days ago)  • #3
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Ok, I think I have a method that will work for what you want to do:

  • Add a new Macro to your profile, in the macro, add a "Macro Script" action
  • Paste in the code from the box below, replacing the "macro name" with the name of the Macro you want to run
  • When this Macro runs this script, it will run the Macro you specified in the script, and then pause VoiceBot listening
  • On the Settings > Configuration tab, set the "VoiceBot Start Command" option
  • When you're done recording, you can then say the VoiceBot Start Command to have VoiceBot start listening again

Code



Please let me know how that works out
16 days ago  • #4
Avatar from Gravatar.com
steve58280
5 discussion posts
Thanks for the code! I am down to a single hurdle, the configuration> start voicebot command works only about half the time. What I notice is it works just after launching vbot but works less reliably over time. I have been using vbot a long time and have tried all the tricks - highly distinguishable words, zero background noise, quality mic - and I'm on a high end PC. Is there a tweak you can give me to keep vbot's listening more active when it is parked in "listening for start command" mode? Its strange because vbot works very reliably in normal working mode, even with long stretches of silence, never a problem.
15 days ago  • #5
Keith Lammers (BFS)'s profile on WallpaperFusion.com
That's really strange, I've never run into that before! I'll do some testing with it here to see if I can reproduce the same issue.
15 days ago  • #6
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Just a quick update to let you know I'm still working on testing this. I've had some weirdness but haven't been able to track it down to anything consistent yet.
4 days ago  • #7
Avatar from Gravatar.com
steve58280
5 discussion posts
Thanks a bunch Keith ! I have been watching and trying to figure out the magic variable that makes it a more consistent listener - perhaps a running script that just toggles the listening kb shortcut twice for a split second that runs every 30 seconds or so would make it more attentive? any way to do that in a running macro without affecting normal operation? - else a maybe a separate vbscript running locally
3 days ago  • #8
Avatar from Gravatar.com
steve58280
5 discussion posts
memory leak? when i turn off the start word option it uses 47M of memory waiting, when start mode is set to a single word it uses over 100M memory and it seems to continue to grow - even in a silent room

anyway the single start phrase option is pretty glitchy
3 days ago  • #9
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Interesting! I'll keep an eye on the memory usage here while testing and see if I can reproduce the same leak. If that's happening, it could be what's causing the issue.
3 days ago  • #10
Was this helpful?    
<< DiscussionsReply