Title

Message

Confirm

<< DiscussionsReply

Macro isn't working, please help!

Avatar from Gravatar.com
Joe Bowers72539
1 discussion post
I'm trying to create a macro for Path of Exile to activate several buff spells that all need to be reactivated every time I die.

To do this manually I press CTRL Q, W, E, R, T, to activate my abilities, then CTRL+click to select 3 more abilities, then CTRL E, R, T again to activate a total of 8.

I thought this would be simple, but it's not working.

I added delays and text to speech to slow it down so I could follow the macro and see where it fails. The first 5 abilities activate without a problem (CTRL Q, W, E, R, T) but when I try to have it CTRL+click a location, then another location, it does it without holding CTRL, so the ability doesn't get assigned to the right key.

I've tried this a couple of different ways, with no success. I tried holding CTRL, then moving and clicking the mouse. I tried using a combined CTRL+click. Neither method works.

Can someone take a look and tell me what I'm doing wrong?

I have 2 more abilities to add to this but I wanted to get this working before I tried adding more to it.
• Attachment: Screenshot 2020-11-02 221840.png [39,050 bytes]
Screenshot 2020-11-02 221840.png
Screenshot 2020-11-02 221840.png
Nov 3, 2020  • #1
Avatar from Gravatar.com
Owen Muhlethaler (BFS)
728 discussion posts
Hi Joe,

I think the issue might be that you have a Ctrl key down sent, and then a Ctrl + Left click. I don't think you need the extra Ctrl key down step. Take that off and see how that works for you.

Let me know how that goes!
Nov 4, 2020  • #2
Was this helpful?    
<< DiscussionsReply